Propositions pour Ovidentia 7

Un article de OviWiki.


Possibilité de sortir des versions issues de CVS en ajoutant un timestamp au numéro de la dernière version taggée de la branche (par exemple 6.7.1-2008-10-01-150000)

Améliorations de fonctionnalités existantes

Adaptation du système d'installation pour avoir des modules embarqués dans la distribution par défaut

Adaptation des délégations pour pouvoir déléguer des fonctionnalités issues de modules

Adaptation des délégations pour pouvoir rattacher un objet du site dans une délégation

Transformation en module des Forums

Transformation en module des FAQ

Transformation en module du Gestionnaire de projets

Nouvelles fonctionnalités

Implémentation de gettext pour la traduction

Plan de site intégré dans le noyau

Modifications des versions minimales des logiciels sur le serveur

Changement des versions minimum pour l'utilisation d'Ovidentia à partir de ovidentia 7.0.0 :

php 5.1.0

mysql 4.1.0


Liste des modules php à rendre obligatoires :

  • gettext (il y a un bug qui force a redémarrer apache en cas de mise a jour des fichiers .mo)
  • calendar
  • json ??? FM : si on demande la version 5.2 de php, ce sera forcément obligatoire ;)
  • gd2